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Purpose
Aircraft Maintenance Program (AMPro) is a computer program which is designed to manage
maintenance information for general aviation aircraft. The program is intended to assist maintenance
personnel and owners of general aviation aircraft in complying with FAA inspection requirements by;
downloading and tracking Airworthiness Directives; tracking unscheduled maintenance and repetitive
maintenance; and creating logbook entries.
This is accomplished by allowing the user to enter information about the aircraft, similar to the
equipment list, and information about historical maintenance and Airworthiness Directive compliance.
The program holds that information in a database and using this information it checks the FAA's
Airworthiness database on the web and alerts users about new or recurring Airworthiness Directives
and scheduled maintenance that needs to be completed. Perhaps the most significant feature is that the
program holds records about previously completed Airworthiness Directives and maintenance allowing
quick proof of previous compliance and where necessary quick identification of the need to re-inspect
or re-service repetitive Airworthiness Directives and scheduled maintenance.

Features
The program consists of:
1) A graphical user interface which allows users to enter and edit aircraft records.
2) A database that holds information about previous compliance.
3) A web interface that checks for new or previously un-complied Airworthiness Directives. These
checks are specific to the airframe, engine(s), propeller(s), and appliances that have been
specified for the aircraft. Missing Airworthiness Directives are added to the database and the
user is alerted.
4) A tachometer and calendar time tracking algorithm alerts you of the need for AD or scheduled
maintenance re-compliance.
5) A form generator which allows you to create logbook entries for Annual and 100 hour
inspections with new AD compliance information included and for scheduled and corrective
maintenance.
6) A report generator allows comprehensive display of information including; Annual Inspection
forms, a full record of historical AD compliance, and a duplicate of the logbooks.
7) A scheduled maintenance entry and tracking routine which allows you to see all historical
scheduled maintenance and to see when scheduled maintenance will next be due. It is also
included in the comprehensive log entries.
8) A corrective maintenance log entry routine which allow you to enter corrective maintenance
work that is performed on the aircraft. This maintenance can be reviewed via user windows on
the program. It is also included in the comprehensive log entries.
9) An aircraft synopsis generator. This lists important information about the aircraft such as owner
information, past inspections, and an AD report.
10) Help menus that provide access to ADs, TCDS, FAR, AC and 337 Forms.
11) A database export and import capability for archival purposes.
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System Requirements
The autonomous windows version of AMPro (Aircraft Maintenance Program) software requires a
computer with Microsoft Windows. The AMPro software relies on two additional software packages
that must be installed on the Windows system to support PDF document creation and viewing.
Software for PDF reading and creation are both necessary. Adobe Reader XI is an example of a
compatible, and very common, PDF reader that is installed on most systems and works well for
viewing PDF files. Artifex Ghostscript is a PDF file creator which is licensed under the GNU Affero
General public License. Ghostscript works in tandem with Adobe Reader in that it creates the PDF
files while Adobe Reader supports viewing, searching, and printing the PDF file. Artifex Ghostscript
can be downloaded from:
http://ghostscript.com/download/gsdnld.html

or from several other software download sites.
The AMPro Installation Guide explains how to install the AMPro, Adobe Reader, and Ghostscript.

Fundamental Concepts
There are some fundamental assumptions that are the basis of the programs functionality. The
following paragraphs will list and describe them.

Assumptions About Current Aircraft and Mechanic
When AMPro performs one of its functions, like creating a log entry or doing an Airworthiness
Directive search, there are a few fundamental things that it must know. The fundamentals include:
1) N number of the aircraft being worked on
2) Tach time of that aircraft
3) The date
4) The mechanic doing the work
From this set of information most other important information can be determined. To eliminate
redundant questions about; the N number, Tach time, date, and mechanic. The program allows these
variables to be set and then it uses those until they are changed. These items are set in the
Equipment->Choose Existing Aircraft and Mechanic menu. This information is not just saved during
the current running session of the program; but it is saved and retrieved even if the program is
terminated or the computer is shut down. The user can quickly determine which aircraft and
information AMPro is using by looking at the status bar located at the bottom of the home screen.
Each time the program is restarted, the program assumes that it will be using the same N number, Tach
time, and mechanic that it used last time it was run. The date, however is updated to be the current
date. When the program is started, the Equipment->Choose Existing Aircraft and Mechanic menu is
presented to the user as a way to remind the user to set up the program to operate on the information
that the user wants to work on. It is important that the user be careful to update the Tach time on this
screen.
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Not all AMPro functions automatically use the information from the last selected aircraft. When editing
previous inspections, Inspection->Edit Existing Airframe Annual Inspection, for example, all
inspections that have been entered will be shown. The user will then select the N number of the
inspection that is desired.

Database saving and backup characteristics
New information is saved to the database each time you click the “Save” button at the end of a series of
inputs. By saving save the data before moving to new inputs there will be a smaller possibility of data
being lost or forgetting to save before exiting. If the program is accidentally shut down then all data
(except, possibly, the last couple of mouse clicks) will have been saved.
Data is saved to the file aircraft.db which is located in the same directory as the rest of the program
code files. This is typically C:\AMPro\... The database directory typically won’t be accessed by the user
outside of AMPro. In case of a computer malfunction AMPro makes backups to aircraft.db in the form
of a text file with a .sql extension. The backup file is saved to the
C:\users\user_name\AMPro_Aircraft_data
directory. Each backup is saved in two files, aircraft.sql and aircraft_date.sql, where “_date” is the
current date and time. These files can be saved to a cloud server or a thumb-drive to ensure that
important data is not lost in the event of a computer malfunction. To learn more of those methods see
the File->Save Entire Database as SQL and the File->Read Entire Database as SQL menu sections
and pay particular attention to the dated backup.
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Tasks Completed Using AMPro
Here is a short list of problems that are solved by AMPro. See the Examples section for further
guidance.
1) It is time for an annual inspection of an aircraft that is new to me and I need to be sure that all
Airworthiness Directives are complied with. In the back of the logbooks I see multiple dog
eared pages showing AD compliance information reaching back to the 1950s. Additionally,
accompanying the logbooks I see multiple redundant years of Airworthiness Directive
compliance worksheets each partially filled out. How can I efficiently compile this information
to determine that a) all Airworthiness Directives have been complied with; and b) which
Airworthiness Directives need re-compliance to satisfy the law?
2) I'm doing my third annual inspection of this particular aircraft. I've checked for new ADs and
resolved those; but what were the recurring ADs? And did I really do a good job in previous
years in proving compliance with historical ADs. Maybe I should just redo the AD search clear
back to 1947. If I had a comprehensive report of AD compliance with enough details to prove
previously compliance I would save a ton of time.
3) How long has it been since the Oil/airfilters/pitot static etc.... were changed or inspected and
what do we need to do today and what scheduled maintenance should we expect in the near
future?
4) I've just completed an annual inspection. Did I check everything and did I get all of the
information needed for the logbook entries?
5) I've just completed an annual inspection. I have the tach time. So what is the total time on the
Engine—no the other engine? What is the total time on the airframe and props and heater?
This program requests the tachometer time and from that it computes the total times on engines,
props and appliances.
6) I'm looking at the logbook entry that I made last year. How could I have made the arithmetic
error and got the total time so wrong? NO, wait I was right last year... I'm confused and this is
taking too much time.
7) I've used AMPro and have a clean record of all Airworthiness Directives from last year. I need
to learn a) if there are any new Airworthiness Directives and b) which Airworthiness Directives
are due again now due to the passage of calendar or tachometer time. One click of the mouse
will show this information.
8) I need a professional, type written Inspection form for the annual I just completed. I need a
form for the airframe, each engine and propeller and I need a list of ADs that I complied with so
that I can sign them and insert them into the logbook.
9) I need a comprehensive list of ADs that have been or need to be complied with. I need the list
broken down into major categories of airframe, engine, and propellers and within those
categories I need subcategories of: needs compliance, recurring, needs future compliance, and
one time compliance previously completed.
10) I need a historical (logbook style) report of all maintenance performed on a given airframe,
engine, or propeller between two given dates.
11) I need to be able to search the logbooks for a specific word.
12) I need a synopsis of the aircraft that gives information such as the Tach and Total time for the
airframe, each engine, the prop, and accessories. It should also give an overview of AD
compliance.
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Reports created
The following files can be created for each aircraft. The files are typically stored in PDF format and
they contain information consisting of Airworthiness Directive information, snippets of logbook entries
from a specific inspection or maintenance service, or they can be full logbook entries.

Full_AD_report.pdf
A full report of ADs for the airframe, each engine, and each propeller, and each accessory divided into
sections listing ADs that need research, need compliance, need logbook entry, Recurring ADs needing
future compliance, or One-time ADs for which compliance was previously completed.
Found at:
Reports->Full Airworthiness Directive Report

N1234X_engine_Front_logbook_pg.pdf
This file is a chronological logbook style list of services for each engine which holds all entries in the
database, or it can be constrained to hold only entries between two user selected dates. This can be
limited to only the most recent entry for the purpose of printing it on a label fixing it into a logbook.
Found at:
Reports->Logbook View (select the book and time period)

N1234X_propeller_Front_logbook_pg.pdf
This file is a chronological logbook style list of services for each propeller which could hold all entries
in the database, or can be constrained to entries between two user selected dates. This report can be
limited to only the most recent entry for the purpose of printing it on a label and fixing it into a
logbook.
Found at:
Reports->Logbook view (select the book and time period)

N1234X_airframe__logbook_pg.pdf
This is a chronological logbook style entry for the airframe which holds all entries in the database, or it
can be constrained to hold only airframe entries between two user selected dates. This report can be
limited to only the most recent entry for the purpose of printing it on a label and fixing it into a
logbook.
Found at:
Reports->Logbook view (select the airframe book and time period)

Unlogged_Onetime_ADs.pdf
This is a list of ADs that have been complied with that have not yet been entered into the logbook. This
list is intended to be printed, signed and affixed into a hard copy paper logbook.
Found at:
Ads->Analyze AD->Needs Log Entry-> Print AD
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N1234X_annual_2014_pg.pdf
This is a print out of the Airframe, engine(s), and propeller(s) annual inspection certificates and also
newly complied with ADs which have never before been logged. This list is intended to hold all forms
necessary to be entered into a logbook following an annual inspection. It is intended to be printed,
signed and affixed into a hard copy paper logbook.
Found at:
Inspection->Enter New Aircraft Annual Inspection-> Save and View Log Entry

N1234X_aircraft.sql
This is a backup copy of this specific aircrafts database. It does not hold records of other aircraft. It is
private and can be supplied to the owner for a private backup of his/her aircraft's E-records.
Found at:
File->Export Single N Number Databases

N1234X_aircraft_synopsis.pdf
This is an overview of data pertinent to a specific aircraft. There are 5 sections included in the aircraft
synopsis; Aircraft Information, Engine Information, Accessory Information, Annual Inspection, and
Summary of ADs. Each section gives information such as the model of a component, serial numbers,
time since overhaul, etc.

Directory organization
AMPro is capable of serving a virtually unlimited number of aircraft. For each aircraft that the
programs serves, various files which the user is interested in are created. These reports include AD
reports, inspection reports, and others as described above. A directory structure has been adopted to
keep the information generated about each specific aircraft organized. All outputs are stored in a
directory that is specific to the aircraft. Each of these sub directories is then stored in the
c:\user\user_name\AMPro_Aircraft_data directory.
For example, if the program were being use to by a mechanic whose user name was Bart_Simpson to
track service for 3 aircraft which had registration numbers of {N111A, N222B, and N333C} the
directory structure would look like:
C:\Users\Bart_Simpson\ AMPro_Aircraft_data
|_____ N111A
|

|_____*.pdf

|
|______N222B
|

|_____*.pdf

|
|______N333C
|_____*.pdf
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Menu
This section describes what each of the menu accomplishes. This section may serve best as a reference
for orientation. In later sections we will describe a typical work flow. The screen shot below shows the
opening screen of the AMPro program.

Notice that there is a row of menus shown. Each function of the program is selected by entering a
menu and sub menu.

File Menu
The file Menu allow the user to handle tasks associated with backing up the entire database or
importing and exporting databases for single N numbers. The following sub menus exist in the File
menu.
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Save Entire Database as .sql
File->Export Entire Database as .sql
Selecting this menu option causes the entire database to be saved under the filename
c:\users\{user_name}\AMPro_Aircraft_data\aircraft.sql. Additionally a second copy is made which
would be named c:\users\{user_name}\AMPro_Aircraft_data\aircraft{save_date}.sql.
Where {user_name} is your username for example it might be Administrator
And where {save_date} is the current date in format %Y_%m_%d__%H_%M where %Y is the
year, %m is the month, %d is the day, %H is the local time hour, %M is the minute. Examples of save
date file names are aircraft_2015_01_02__10_50.sql. In this example the backup was made at
10:50AM on January 2 of 2015. This backup can be copied to a server.
This is the best way to back up the entire database. It can be uploaded to a server or thumb-drive disk.

Read Entire database from .sql
File->Import Entire Database from .sql. This menu option causes the database to be read from the
c:\user\{user_name}\AMPro_aircraft_data\aircraft.sql file into the program's internal working database.
If the file does not exist an error message is returned. This would be how you would restore the
database from a server or thumb-drive.

Export Single N Number Databases
File->Export Single N Number Databases. This menu allows an N_number.sql file to be created and
placed in this aircraft’s directory. The data held in that file is specific to this aircraft and can be used
for private backups. The file is placed at
c:\user\administrator\AMPro_aircraft_data\N1234X\N1234X.sql. N1234x is the directory where the
data is placed assuming that the N number of the aircraft is N1234X. N1234X is replaced by the
N_number of the aircraft that is being worked on. That N_number is selected in the
Equipment->Choose Existing Aircraft and Mechanic.
There are two submenus for exporting N number databases:
File->Export Single N Number Databases->Import Single N Number Database with Conflict
Overwrite
and
File->Export Single N Number Databases->Import Single N Number Database without Conflict
Overwrite
Importing with conflict overwrite allows you to import data for a single aircraft into your central
database. If certain entries or data have been modified in the new database then these will update these
values. If the Import without conflict overwrite option is used then these entries will not be modified
and only new data will be entered. Data overwrite may be useful, for example, if an aircraft owner
wants to supply his new mechanic with specific information, such as maintenance logs or past
inspections, about his aircraft.

Exit
This Menu selection exists AMPro.
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Equipment Menu
The Equipment menu enables the program user to enter or edit information about the aircraft's
equipment list, the owner, and the A&P mechanic

Choose Existing Aircraft and Mechanic
This menu allows for the selection of the N number, the date, and the tachometer time of the aircraft for
which work is to be entered. It also identifies the mechanic that performed the work. A screen shot of
the Equipment->Choose Existing Aircraft and Mechanic is shown below.

The current date is determined by the computer’s date and is auto-entered; but it can be altered if
necessary, for example to log work performed on a previous day. The most recently reported
tachometer time for the aircraft is auto-entered into the tachometer time field but since the tachometer
time has probably progressed since the last work was performed on the aircraft, the tachometer time
should be updated to match the aircraft's current tachometer time. The most recently reported
tachometer time is entered as a reference to the user.
After this information is entered, it will be used for work performed until it is changed. For example, if
you direct the program to perform an AD search, or if you enter a new annual inspection, the aircraft
13
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and mechanic loaded at this screen are assumed to be the target of the AD search or inspection.

Edit Existing or Add New Aircraft or Equipment
This menu allows the aircraft's equipment list to be entered or updated. The primary reason for
building the equipment list is that the items in the equipment list are used to 1) search AD, 2) track
scheduled maintenance, 3) provide items in the Annual inspection GUI questionnaire and reports. If
you are working on an aircraft that is new to your records, this is where you enter information about the
airframe, its engine(s), its propeller(s), its appliances, and its scheduled maintenance items. As
mentioned, the equipment list information is used for finding Airworthiness Directives, for determining
the total time of a component, and for filling most of the fields in the inspection and maintenance data
input screens. When you select Equipment->Edit Existing or Add New Aircraft or Equipment menu,
you will be presented with the following screen.
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If you intend to enter a new aircraft you should highlight the Enter New N number line at the top of the
listbox as shown above and the click the Select highlighted button. This will cause a new entry to be
displayed which will allow you to enter an airframe via its N number. After you enter the N number and
click Edit or Add, the program will go to the FAA's aircraft registry and gather most of the information
needed in the AMPro database. Entries with labels that end with a * are required.

If you intend to edit one of the existing aircraft, you would highlight the N number of the aircraft
whose equipment list you want to edit and then click the select highlighted button.
If you had selected N311N and then selected the Edit or Delete Right Engine, the following screen
would present itself.
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From this screen we see that the equipment list for N311N includes an airframe, 2 engines, 2
propellers, and a cabin heater. In the screenshot above, the Right engine has been selected for editing.
Any one of the components (airframe, right engine, left engine, right propeller, left propeller, cabin
heater) can be edited by highlighting it and then clicking the edit button. After you complete the edits
you should select the Save button. This will close the Right engine edit window; at that point you are
allowed to edit any other component on the equipment list or to add a component to the equipment list.
The top four items in the “select a component to update” listbox allow you to add an engine, propeller,
an appliance, or a scheduled maintenance item. When you select Add a(n)… you will be presented
with menus that help define the component. Entry boxes labeled with an asterisk (*) are required
entries.
The FAA AD URL entry is critical, this entry will usually be filled out by the program if the component
can be found in its internal or the FAA’s databases. If you put “null” on the FAA AD URL, AMPro will
not try to do an AD search for that component. If you leave it blank, the AD search process, when
executed later will issue a warning.
The time since the last tachomenter change is another critical entry. We need to keep total time in
service records for each airframe, engine, propeller, and appliance. Typically the tachomenter or hobbs
meter are used. When an aircraft and tachometer are both new, the hobb or tach tell the total time on all
components. As aircraft age, tachometers fail and must be replaced. Typically the replacement
tachometer starts with a time of 0 hours. To keep accurate records, we must track the time on all
components when the tachometer was last changed. In the example of N311N's right engine shown
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above, we see that the TTEng at last tach change was 770.4, the TSMOH at last tach change was 770.4
and the TSTOH at last tach change was 0.0. This means that the tachomenter failed and was replaced
with a zero time meter when the engine had 770.4 hours total time and since major overhaul. And the
engine had been given a top overhaul at the same time as the new tachometer was installed. So it is
required that you determine the total times on components and enter those total times when you enter
or edit the equipment lists.

Mechanic Data
This menu allow a mechanic’s name and A&P number to be entered. This information allows AMPro
to automatically append the A&P number to log entries when a mechanic's name is entered in the
Choose Existing Aircraft and Mechanic menu.
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Airworthiness Directives (ADs)
This menu of AMPro provides support for sorting Airworthiness Directives into logical categories
which allows the owner and maintenance personnel to keep the actions required by each of the
applicable ADs conceptually compartmentalized depending on the actions required by the AD for the
aircraft that is currently being worked on. This will save time by allowing the ADs that need
compliance to be brought to the attention of the owner or mechanic. One-time ADs that have
previously been complied with can have their compliance well documented to provide confidence that
they were properly serviced. With the assistance of this program the AD sorting process is much like a
card game. Each new AD is analyzed by the maintenance personnel and then moved to the proper
category. When an aircraft is first entered into the records, all ADs must initially be downloaded and
reviewed. This might be done prior to the first annual inspection. After the initial sorting is completed
future AD analysis is a very quick process. The following figure shows the AD analysis process by
showing the work state that each AD can be stored in and the action taken by the person running the
program to sort AD into the various work states. The goal of the AD analysis process is to move all
ADs out of the Needs Research or Needs Compliance work state and into the bottom states—either

Compliance Completed or Needs Future Compliance. The text that follows the work state flow diagram
will describe the decisions that the operator must make to move an AD from one state to the next.
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AD synopsis
The current state of the ADs for a given aircraft can be seen by selecting the Ads->Analyze ADs menu
item. When this is selected you are presented with the following screen.

This screen shows the 6 AD analysis work states and it shows the number of ADs held in each of the
work states for this aircraft. In the example above the last AD downloaded from the FAAs AD database
was performed on October 12, 2015 and we have 1 AD that needs research, no ADs that need
compliance or log entry, 21 that have been found to have their compliance completed, and 3 that need
future compliance.

Download ADs
AMPro uses the equipment list information previously entered in the Equipment->Edit Existing or Add
New Aircraft or Equipment menu to go to the FAA’s AD website and search the FAA's Airworthiness
directive database. The search is initiated by selecting ADs->Analyze ADs from the program's menus
and then selecting the Download ADs list box item. You must have an internet connection to perform
the AD download as the ADs are read from the FAA’s AD web accessible database. Each time a search
is executed, the ADs found in the FAA's database are compared against the ADs that are found in the
local database. Any AD found in the FAA's database that is not found in the local database is
considered as new and is added into the local database and the work state for that AD is assigned to
Needs Research. ADs that are found in the FAA's database that already exist in the aircraft's local
database are kept undisturbed in the local database. At the end of the AD Download the program will
inform the user about the number found on the FAA's database and how many of those found are new
to the local database and how many previously existed in the local database. If this is the first time that
an AD search has been executed for this aircraft. All ADs that pertain to this aircraft’s airframe,
engine(s), propeller(s), or appliances will be downloaded and this typically includes 30 to 100 ADs.
Subsequent downloads will yield only ADs that have been added to the FAAs database since the last
download—usually 0 or 1 AD.

Needs Research
ADs that have been downloaded from the FAA's database and have never been evaluated in this
program are loaded into the Needs Research work state. When the user clicks on the ADs->Analyze
ADs menu selection and then selects the Needs Research listbox item, they are shown a list box of all
19
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ADs that need research.

To analyze the ADs in the Needs Research work state one of the ADs must be selected and then the AD
must be assigned, depending on the circumstance, to one of the three categories which are:
1) One-Time AD Not previously logged
2) Recurring
3) One-time previously complied with
This is done by clicking one of the three radio buttons in the Update ADs area on the right hand side of
the screen.
To assist the maintenance personnel in making the assignment, when each AD is initially loaded from
the FAA's database, the program references another database which gives suggestions about AD being
either recurring or one-time. If it is recurring it gives suggestions about the recurrence period. This
guidance is shown by pre-highlighting either the Recurring or the One-Time not previously complied
with. These are only suggestions and can be overridden by the maintenance personnel.
To assist the maintenance personnel in knowing what the FAA requires in the AD, the program
provides a VIEW AD button which, when selected, opens a window and displays the FAA's text of the
AD. This allows the maintenance personnel quick access to the legal requirements of the AD.
Once oriented on the legal requirements, the maintenance personnel will probably review the AD
section of the aircraft's original hard copy logbooks to see what has or has not been done to service the
AD by maintenance personnel in the past. If the AD as it applies to this aircraft is recurring and if the
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program had pre-highlighted the recurring button as a suggestion, the maintenance personnel will click
the recurring button to confirm that selection. If however after reviewing this aircraft's previous
maintenance, the AD is determined to not be recurring and to have been previously complied with as a
One-Time AD, the maintenance personnel will simply click the One-time previously logged button and
the program's suggestion that the AD may be recurring is overridden.
As a rule the program will suggest the worst case scenario. If an AD can be either one-time or
recurring, the program will pre-highlight the recurring box. If an AD can be either recurring at 7 years
or at 1 year, the program will offer a 1 year recurring period. If the AD can be one-time previously
complied with or one-time not previously complied with and the program has no information to suggest
that the AD has been complied with the program will pre-highlight the one-time not previously
complied with.
If the user disagrees they simply click one of the other more appropriate buttons. Once an AD has been
through the Needs Research evaluation it will never be reloaded into that work state unless the user
chooses to delete and reevaluate that particular AD.
In a typical first analysis situation of an aircraft that has never been in the system, the initial AD search
will deposit 40 or 50 ADs in the Needs Research work state. After the initial sorting is completed, the
Needs Research work state remains empty until the FAA issues another Airworthiness directive that
applies to this aircraft, engine, propeller, or appliance.
If the equipment list has been properly initialized in the Equipment->Edit existing or Enter New
Equipment menu this program will be aware of the aircraft's equipment, engine/propeller count and
position, and where an AD applies to both engines or both propellers there will be an AD entered into
the database for each of both engines or props.
If the user chooses to assign an AD to One-time Not previously complied with, the next state for that
AD will be Needs Compliance.
If the user chooses to assign an AD to One-time previously complied with, additional information
which proves and identifies the previously compliance will be requested and the next state for that AD
will be One-Time previously complied with. It will remain in that state as proof of previous compliance
forever unless purposefully deleted.
Multiple ADs listed in the Needs Research listbox can be highlighted at one time and can all be moved
to the One-Time previously complied with work state in one single click. This speeds the initial
assignment in the event that ADs are identified en-mass in the back of the logbook as having been
previously complied with.
When the user identifies or agrees with the programs suggestion that an AD is recurring, they select the
Recurring option. This results in a few additional questions being asked about the recurrence period
and then the AD is assigned to the Needs Compliance work state.

Needs compliance
When the user clicks on the ADs->Analyze ADs->Needs Compliance menu option they are able to
work with ADs that have previously been determined to need compliance. In this state, the user must
either certify compliance or defer compliance.
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The first time that an AD is evaluated in the Needs Compliance work state, the user will need to
determine if compliance is necessary now or if it can be deferred until a later date. For example some
ADs are recurring on a very long period. If the AD does not need to have initial compliance for 5 more
years, the user can defer the compliance until a future date or tachometer time. If the AD is deferred,
its work state will be assigned to Needs Future Compliance.
If the AD needs to be completed now, after completion of the required actions you would click on the
certify compliance button and it will be moved into the Needs Log Entry work state.

Needs Logbook Entry
When the user clicks on the ADs->Analyze ADs->Needs Logbook Entry menu option they are able to
work with ADs that have previously been complied with and that now need to be entered into the
logbook. ADs in this work state can be printed. When printed on label stock, it is intended that they will
be signed and entered into the hard copy logbook. After printing, if they are a recurring AD, they will
be moved into the needs future compliance work state and will be rescheduled for future compliance at
the proper time. If the AD is a one-time AD, after it is printed, it will be moved into the Compliance
Completed work state.

Compliance Completed
When the user clicks on the ADs->Analyze ADs->Compliance Completed menu option, they can view
or update information on one-time ADs that have previously been complied with and no longer need
further compliance.
ADs in this work state are held here as a record that all necessary work has been completed. In this
state they can have information about details of their compliance updated. A case in point would be a
situation where many ADs were evaluated and moved from the needs research state to this state in a
single mass assignment. After that initial assignment is made the user may want to come back and add
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specific information to each AD to reinforce the data that proves that compliance was completed.

If an AD were mistakenly moved to the compliance completed work state, it can be deleted. And the
next time that AD are downloaded from the FAA the deleted AD will be placed in the Needs Research
state. This essentially give you a chance at a do-over if incorrect assignments were made.

Needs Future Compliance
When the user clicks on the ADs->Analyze ADs->Needs Future Compliance menu option, they can
view ADs that will be needing future compliance at some future total time or Calendar date. ADs in
this work state remain in this work state until the calendar date or the tachometer time progresses to the
point that the AD needs to be moved into the Needs Compliance state. Alternatively, the user can
review the ADs and make an early compliance assignment as part of an annual inspection such that the
AD will remain in compliance for the longest possible period of time into the future.

Recurring ADs cycle through the Needs compliance, needs log entry, needs future compliance state as
calendar, total time and recertification process progresses.
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Inspection
The Inspection menu is where you can enter an annual inspection or edit an inspection that was
recently completed. You have the choice of entering a new inspection or editing an existing inspection.
Inspections are entered or edited by selecting the Inspection->Enter New Aircraft Annual Inspection or
Inspection->Edit Existing Aircraft Annual Inspection. The following screenshot shows the inspection
screen.

This portion of the program is aware of the number of engines and propellers on a given airframe and it
creates the correct number of questionnaires for the aircraft and engines. Additionally, the database
knows if an aircraft is experimental or not and it will create the correct verbiage on the inspection
report so that the report matches the aircraft's certification. If you indicate that the aircraft is not
airworthy the inspection report will state that. Once the user is satisfied with the data in all fields of the
inspection questionnaires an inspection certificate can be printed. The program will print reports for the
airframe, for each engine, and each propeller.

Enter New Aircraft Annual Inspection
The Inspection->Enter New Aircraft Annual Inspection menu allows a new inspection record to be
entered. When you select a new aircraft inspection the program will check the due date of the ELT
battery, it will check to see that the ADs were downloaded within the last 2 weeks, and it will make
sure that there are no ADs in the Needs Research or Needs Compliance work states. Warnings will be
issued if any of these issues exist. The program then presents a screen of questions where you enter
data that you acquired during the inspection of the aircraft. The data requested will be specific to the
aircraft that is being inspected. For example if the aircraft has two engines and propellers, the
program’s data input screen will request data for each of the engines after making it clear the position
of the engine and propeller for which it is asking for data for. Once the data has been entered you have
the option to save the data or save the data and generate inspection forms. If you have completed the
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inspection you will likely want to save and generate forms. If you are only partially done with the
inspection you may choose to save the data only. Later you can edit the inspection and update the
information that you are saving in this step. When report printing is requested for a new annual, in
addition to the inspection reports, all ADs that are in the need logbook entry work state will be created.
Once the report forms are created and saved the computer’s PDF viewer will be opened with the
inspection form displayed. From there you can print the inspection report.

Edit Existing Airframe Annual Inspection
The Inspection->Edit Existing Airframe Annual Inspection menu allows access to existing inspection
records. This menu allows you to review and update old inspections. Here is where you can complete
the entry of any lingering items that were not entered when you initially entered the new aircraft annual
inspection date. For example if a new ELT battery has just arrived, you can install the battery, test the
ELT, update the report, and then the inspection can be printed.
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One feature in the inspection menu is that inspection can be ordered by date, owners name or N
number. This allow you quick access to the information stored in the database.
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Maintenance
The program comprehends two types of maintenance. Scheduled maintenance includes items, like oil
changes, that need to happen on a repetitive basis. Corrective maintenance, on the other hand, is
maintenance that was unexpected—something broke and was fixed.

Scheduled Maintenance
By selecting the Maintenance->Scheduled maintenance each scheduled maintenance item can be
viewed.
Scheduled maintenance items can be viewed by airframe, engine, or propeller categories and the entries
can be sorted into arrangements of either next due or historical. In the Next Due view it shows only
one copy of each scheduled maintenance item and it shows when they will need to be serviced next.
The items are ordered such that the most imminent service is at the top of the list. To enter a new
service you would highlight the entry that you wish to update, for example, highlight “engine Oil
Change”, then type the log entry, and verify the data and tach time and the click log new service. You
must pay attention to the select view item. It must be set to next due to see services ordered by the next
one to be needed.

Alternatively, a historical record that shows all entries of service in the database; and the order is
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chronological.

Setting Up Scheduled Maintenance
To initially set up a schedule maintenance item several details about its maintenance period must be
entered. To do this go to Equipment->Edit Existing or Add new Aircraft or Equipment. Then select the
N number of the aircraft that you wish to add the scheduled maintenance item for and then select add a
Scheduled Maintenance Item.

To delete or update information about a Scheduled maintenance item go to Equipment->Edit Existing
or add new Aircraft or Equipment. Select the N number of the aircraft that you wish to add the
scheduled maintenance item for and then select the item you wish to delete or edit.
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Corrective Maintenance
Corrective maintenance reports simply allow the user to log what was done and when similar to a
traditional log entry. To enter or review a corrective maintenance item select Maintenance->Corrective
Maintenance.
A list of previously entered corrective maintenance items will be shown (if any have previously been
entered) and at the top of the list is a selection labeled, “Enter new maintenance Log entry”. If you
select Enter New Maintenance Log entry you will be asked for a new title, logbook entry, date, time,
and maintenance personnel. After saving the new entry you can create a log entry if you wish.
To view an existing corrective maintenance entry, click on the entry you wish to learn more about. The
details will be shown—title, logbook entry, date, time, and maintenance personnel. You can update or
print the entry.
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Reports
The Reports menu provides an overview of maintenance. The reports can be in the form of
chronological logbook style entries, Airworthiness Directive overview reports, or an aircraft synopsis
report.

Logbook View
In the Logbook view, data from all inspections, corrective maintenance, and scheduled maintenance are
sorted into a chronologically ordered reports and can be printed logbook style. The user can choose if
they want see the airframe log, the engine(s) log, or the propeller(s) log. The user can also select the
period of time that the log report will be created for.

Full Airworthiness Directive report
This report will sort all ADs into categories of; Airframe, Engine(s), and Propeller(s) and then also into
subcategories of; needs research, needs log entries, needs compliance, compliance completed and needs
future compliance. This report is a very complete and fairly concise analysis of the aircraft's AD
situation.

Airplane Synopsis
This report gives an overview of the aircraft by giving information grouped into 5 categories; aircraft,
engine information, accessory information, annual inspection, and summary of ADs. The aircraft, engine information, and accessory information sections give information such as manufacturer, model,
and total time on the component. Annual inspection lists the date of the last annual inspection, tach
time, and TSMOH.
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Help
Provides access to users guides and information.

Get AMPro Revision
Selecting this menu item will cause a pop-up box to appear which will display the revision number of
the program.

Get AMPro License info
Selecting this menu item will cause a pop-up box to appear which will display the serial number of the
program and the number of days that remain on the license. Once the license expires the program will
only allow the update license screens to operate.

Update License
This menu item allows you to update your license. The license update process is as follows: When
your license is within 2 weeks of expiration you will be presented with the Get AMPro License info
screen when you open the program. This is done to remind you to contact the vendor for a license
update. If you choose to update the license, you will need to record the serial number and provide it to
the vendor. To update the license, the vender will provide you with a certificate key through email. The
key is in the form of YYYY-mm-dd_SerialNumber_code. For example it would look like 2015-0630_12345_xxxx. This certificate key is copied from the email and is pasted into the entry box presented
when you select the Help->Update License menu. Once you have entered the license certificate, select
update. AMPro will then evaluate the code and if correct the program will display the new license
expiration date. If the code is invalid, the update certificate is invalid and the license will not be
updated. If this happens, you should re-try to enter the code or contact the vendor. When contacting the
vendor be sure that the correct serial number is provided. When entering the code, it may be easiest if
you highlight the license certificate code in the email, right click on the highlighted code, select copy
and then move your mouse to the update entry box, right click and select paste. Free evaluation licenses
are typically 2 months.

Open User’s Guide
Selecting this menu option will open this file.

Display license file
This selection shows the license agreement.
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Library
Display Logbook Archive
You may choose to scan old logbook entries and AD compliance records. As an owner this might be
done for the purpose of logbook backup. The scanned files can be saved on cloud storage. As a
mechanic, this may be done to provide proof of the original AD compliance. These original records are
the basis of the information you entered into the database. To simplify the initial setup of an aircraft’s
AD compliance, for example, some mechanics may not choose to spend all of the time required to key
in all of the information copied from the original logbooks which provide proof of compliance for an
old one time AD. Rather, they may choose to move a large number of ADs from needs research to
Previously complied with by selecting multiple ADs in the needs research listbox and then as an
explanation of compliance, they would simply enter “see logbook archive”. After clicking save, all
selected ADs would be moved from the Needs Research work state to the Compliance Completed work
state. Then as proof of original compliance you would place the file containing the scanned copy of the
original logs in the archive directory. The scanned format must be PDF the location of the files must be
Windows
C:/users/your_user_name/AMPro_aircraft_data/archived_logs/N_number/*.pdf.
For linux
~/Home/AMPro_aircraft_data/archived_logs/N_number/*.pdf.
When you select Help->Open logbook Archive
AMPro will search the directory for the currently selected aircraft and if any .pdf files are found a pdf
viewer will be opened and the files will be loaded. You can then view them as reference material or as
proof.

Open FARs
This selection opens a web browser to the FAA’s FAR page. From here you can select the Chapter of
the FAR that you are interested in.

Open Type Certificate Data Sheets
This selection opens a web browser to the type certificate data sheets where you can alphabetically
select the data sheet of the aircraft, engine, prop, or appliances.

Open 337 instructions
This selection opens a web browser to an advisory circular on 337 completion.

Open 337 Form
This selection opens a web browser to an advisory circular with 337 form that you can complete.

Open advisory circular directory
This selection opens a web browser to an advisory circular selection directory where you can select any
advisory circular.
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Open inspection checklist
This selection opens a web browser to FAR 43 appendix showing the list of items that must be checked
during an inspection.

Open maintenance description.
This selection opens a web browser to FAR 43 appendix showing the list of items that are preventative
vs major modifications and maintenance.

Example Work Flow
1) Enter mechanic's credentials. This is accomplished in the following menu
Equipment->Edit Mechanic Data This needs to be done only once for each mechanic or owner/pilot
that will be entering maintenance records.
2) Enter Aircraft's equipment list and owner’s information. This is accomplished in the following
menus
To add an aircraft:
Equipment->Edit Existing or Enter New Aircraft or Equipment->Enter N_number
To add an engine:
Equipment->Edit Existing or Enter New Aircraft or Equipment->Select N_number->Select a
component to update->Add an Engine
To add a propeller:
Equipment->Edit Existing or Enter New Aircraft or Equipment->Select N_number->Select a
component to update->Add a Propeller
To add an appliance:
Equipment->Edit Existing or Enter New Equipment->Select N_number->Select a component to
update-> Add an Appliance (optional used for AD search of Appliances)
To add a scheduled maintenance item:
Equipment->Edit Existing or Enter New Aircraft or Equipment->Select N_number->Select a
component to update->Add a Scheduled Maintenance Item (Optional, used in
Maintenance->Scheduled Maintenance)
3) Download ADs from the FAA's database. This is accomplished in the following menus.
ADs->Analyze ADs->Download ADs
4) Sort all ADs out of the Needs Research and Needs compliance work states by reference to
previously completed ADs from old logbook entries and by compliance with the AD where
necessary.
To view ADs that need research:
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ADs->Analyze ADs->Needs Research
To view ADs that need compliance:
ADs->Analyze ADs->Needs Compliance
The “Needs Research” and “Needs Compliance” sections are the minimum set needed to be sure that
you have complied with ADs but other menus will help you understand the AD situation of the aircraft.
To view ADs that need log entry:
ADs->Analyze ADs->Needs Log Entry (this is automatically done by the inspection menu)
To view ADs for which compliance has been completed:
ADs->Analyze ADs->Compliance Completed
To view ADs that need future compliance:
ADs->Analyze ADs->Needs Future Compliance
5) In Scheduled Maintenance you can view the maintenance items and view by “Next Due” or
“Historical” as well as specify which types of maintenance items to view which options such as;
“All”, “Airframe”, and “Front Propeller”, depending on what components are associated with
your airplane. This is not required by part 91 but will be very helpful for part 135. It can be
done as follows.
Maintenance->Scheduled Maintenance then Select View->Next Due
6) Inspect the aircraft per annual inspection checklist and enter new inspection information
Inspection->Enter New Aircraft Annual Inspection then Save or Save and View Log Entry
7) Print the inspection reports including ADs on label stock.
Inspection->Enter New Aircraft Annual Inspection then Save and View Logs Entry
8) Sign the ADs and stick them in the Logbook.

Entering a new Aircraft, Engine and Propeller
Go to Equipment->Edit Existing or Add New Aircraft or Equipment menu. Select the Enter New
N_number option from the list box by either highlighting Enter New N_number and then clicking on
Select highlighted button or by double clicking on Enter New N_number. Enter the N number of the
aircraft that you wish to add to the system in the N Number box and click Edit or Add.
This opens a window that allows you to enter information about the airframe. At the same time, the
program will prepare a query to the FAA's registration database. When you click OK, the program will
query the FAAs database and will fill in as much information as possible into the Enter or edit airframe
information here window. The key information is the Manufacturer’s name, the model and the FAA AD
URL. Once this information is entered by the program, you can edit it if necessary.
At this window, you must enter the TTAF at last tachometer replacement (see the next paragraph for an
explanation) and verify that the FAA AD URL was filled in. Other fields which cannot be filled in by
the FAA database query, such as TTAF at last tachometer replacement, the owner’s telephone and email
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address should be filled in by referring to the aircraft's logbooks. Once the screen is filled out, click
Save which will return you to the Select an N number menu. The next several paragraphs discuss
computation of total time from tach time and details of how the AD URL is obtained. Once these items
have been accomplished, skip to the Entering the Engine, Propeller, and Appliances section.
The AD URL is used to search the FAA's AD database for ADs. If you do not have a valid AD URL
then when you enter the Ads->Analyze Ads->Download ADs menu the program will display a warning
pop up box. The FAA's AD database only holds ADs for aircraft that are registered as Standard
Airworthiness. If your aircraft's N number is registered as experimental, when the FAA's registration
database is searched, the value of NULL will be placed in the AD URL. The NULL tells the program
not to search for AD's for this aircraft. If you do not want the program to search for ADs for the
airframe you are adding, and you do not want to see the warning pop up, you can enter NULL into the
AD URL window and the program will know later on to ignore the AD search for this component.
Adding null for a standard airworthiness aircraft will preclude AD searches. It is the obligation of the
inspector and owner to comply with ADs so be careful about entering NULL in a standard
airworthiness aircraft's AD URL.

Computation of Component Total time
AMPro software has a feature that is designed to simplify record keeping. In most cases only the
tachometer time needs to be entered and then the total time is computed and entered into database
records by referencing the tachometer time. In order for AMPro to compute the aircraft's total time
from the tachometer time it must know the aircraft's total time when the tachometer was last changed.
So for example, if an aircraft had its original tachometer and the Total time on the airframe was the
same as the tachometer time, then the TTAF at last tachometer replacement would be 0.0 meaning that
the airframe had 0 hours on it when the new (original) tachometer was installed.
As a second example, assume an aircraft has 9200 hours total time on the airframe and it has been
through several tachometers. Assume that the last time a tachometer was replaced was when the
airframe had 8000 hours and the current tachometer time is 1200. In this case you should enter 8000 as
the TTAF at last tachometer replacement.
A third example involving an aircraft that has had its engine and tach both replaced is more interesting
and realistic. Assume that the airframe has 9000 hours total time, the engine was replaced at 7000
hours, the tachometer was replaced at 8000 hours, the engine was overhauled at 8200 hours, and top
overhauled again at 8800 hours. In this case, in the menu:
For total time on the airframe use the following menu and value:
Equipment->Edit Existing or Add New Aircraft or Equipment->Nxxxxy->Edit or Delete
Airframe and Constituent Components->TTAF at last Tach Replacement, the user would enter
1000.0
For total time on the engine since new use the following menu and value
Equipment->Edit Existing or Add New Aircraft or Equipment->Nxxxxy->Edit or Delete Nxxxxy
Front Engine->Enter or edit engine information here.
In the Enter the hours on the following items when the tachometer was last changed box change
the value of TTEng to 1000.0. (The number is positive because the engine was new at 8000 hrs
TTAF prior to the tachometer being replaced at 9000 hrs TTAF).
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For total time on the engine since overhaul use the following menu and value
Equipment->Edit Existing or Add New Aircraft or Equipment->Nxxxxy->Edit or Delete Nxxxy
Front Engine
In the Enter the hours on the following items when the tachometer was last changed box, the
user would enter -200.0 in the TSMOH box ( the number is negative because the engine was
overhauled after the tachometer being replaced.)
For total time on the engine since TOP overhaul use the following menu and value
Equipment-> Edit Existing or Add New Aircraft or Equipment ->Nxxxxy->Edit or Delete
Nxxxxy Front Engine
In the Enter the hours on the following items when the tachometer was last changed box enter
the hours in the TSTOH box, the user would enter -800.0 ( the number is negative because the
top of the engine was overhauled after the tachometer being replaced.)
Remember that if the tachometer is older than the engine, prop, or overhaul of the engine or prop, then
the hours on that item (i.e. TTEng, TSMOH, TSTOH, TTProp) when the tachometer was last changed
will be negative.

Airworthiness Directive FAA URL
AMPro downloads ADs from the FAA's database because it is the official source of ADs. The database
holds ADs for all certified aircraft, engines, propellers, and appliances. To enable the software to search
for the correct ADs the FAA AD URL field must be loaded with the correct URL. This can be
accomplished in several ways, 1) when you enter a new N number the program will search the FAA
registry and will create the AD URL, if possible (this is the normal way). 2) If the previous option
fails, it is usually because your aircraft, engine, or propeller is not in the AC_db.sql database which we
provide. If that is the case and if you contact us, upon your request, we may provide a database update
of the AC_db.sql database which holds the more common airframe, engine, and propeller's URLs. Or
3) in the most general and most difficult case you will have to manually find and enter the URLs you
need. This is necessary only if option 1 and option 2 above fail. The following text will describe how
you can find and enter the URL by doing your own search. Here is an example of how to find the
URL. Go to the FAA's AD web-page at
http://www.faa.gov/regulations_policies/airworthiness_directives/
In the Search by box enter your best guess at the aircraft's manufacture and then the model number.
This is a bit tedious in that you may need to try several searches to find the correct search key. If you
are too general you will get many ADs that don't apply. If your search key is too specific or if it is
sensible but incorrect you will get no ADs. So, here is an example
Enter “Beechcraft Bonanza” and you get “no Results”. Enter “Hawker Beechcraft” - this used to work
but no longer does with the reorganization of Beechcraft after bankruptcy. Enter “Raytheon”-nothing.
Enter “Beechcraft”--wow, this works way too well and you get 630 ADs for all sorts of aircraft built in
the 1930s on up. Refine your search by entering “Beechcraft D35” - this returns 16 ADs which apply
to the model D35 bonanza. Now that you've found it highlight and copy the link which is
http://www.faa.gov/regulations_policies/airworthiness_directives/search/?q=Beechcraft+D35
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into the FAA AD URL field in the Enter or edit airframe information screen. This will provide the
information necessary to facilitate an AD search of the airframe ADs.
Some aircraft have been purchased by companies after original manufacture stopped producing the
airplane. For example, for a Rockwell Commander 114 aircraft you will need to search for “CPAC
114”. CPAC refers to the current owner of the type certificate for the 114. Searching for CPAC 114
shows 11 ADs and produces the following link
http://www.faa.gov/regulations_policies/airworthiness_directives/search/?q=cpac+114
which you would enter into the FAA AD URL.
If you use the following search key “Cessna aircraft company 182” you will get 62 ADs and the
following URL
http://www.faa.gov/regulations_policies/airworthiness_directives/search/?q=cessna+aircraft+company
+182
If you refine the search to “Cessna aircraft company 182A” you will constrain your AD to those that
apply only to the A model of the 182 and you will reduce your AD count to 28.
Stinson 108 is found by searching “Univair 108”.
Load the FAA AD URL with nothing if you do not want to search for ADs for the component.
Once you have filled out all of the fields correctly click “save”. This saves the airframe in the database.

Entering the Engine, Propeller and Appliances
Once the airframe information has been entered by N number and you want to add information about
the engine that is on the aircraft, go to Equipment->Edit Existing or Add New Aircraft or Equipment
menu again and highlight the N number of the airframe that you wish to add components to and click
Select. Then in the select a component to update listbox select Add an Engine and click Select. A new
listbox is displayed showing engine manufactures. You should select the manufacture of the engine
which is on the aircraft by double clicking on the manufacture. Once the manufacture is selected
another listbox is opened which shows engine models. Use the scroll bar to scroll down if necessary to
find the correct model and double click on it once it has been located. A third listbox is displayed with
the engine series information. Once the series has been found, double click on it and click Save. A
screen with the engine manufacture, model and AD URL pre-filled in will be shown. You should fill in
the remaining information and click Save to save the engine information.
Repeat the process to add information about a propeller. The database holds over 1000 engine and
propellers; however, if your engine or propeller is not shown you can either contact us for help adding
your equipment to the database or you can synthesize the AD URL as described above.
The AD URL is used to search the FAA's AD database for ADs. If you do not have a valid AD URL,
when you enter the Ads->Analyze Ads->Download ADs menu the program will display a warning
URL. If you do not want the program to search for ADs for the engine, propeller, or accessory you are
adding, and you do not want to see the warning pop up, you can enter NULL into the AD URL window
and the program will know later on to ignore the AD search for this component.
You can again repeat the process to add information about an appliance such as a magneto or a heater.
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Entering a Scheduled Maintenance Item
You can repeat the process to enter data about a scheduled maintenance item. Scheduled maintenance
items provide information for repetitive services that you may choose to schedule. This would
typically include items like oil changes, air filter changes. Maybe you might choose to include tire and
battery changes and could possibly include engine overhauls if you choose to automatically overhaul
engines at TBO. To do this, go to Equipment->Edit Existing or Add New Aircraft or Equipment menu
and select Add a Scheduled Maintenance Item. Fill out the information about the type of consumables
and the maintenance period and click save. You will be able to track, log and manage services in the
Maintenance->Scheduled Maintenance menu area.
Once you have entered the equipment list for an aircraft which includes an Airframe, its Engine(s),
Propeller(s), appliances and scheduled maintenance items. The program can be used to enter
inspections, enter maintenance, search ADs and generate reports.
At this point, you have entered all of the aircraft's fundamental information—its equipment list. This
information will be used to support: AD searches; the documentation of inspections and maintenance,
including scheduled maintenance, and corrective maintenance; and for the generation of reports

Search ADs
Prior to entering an inspection you will probably want to be sure that all ADs are complied with. To do
this follow the instructions to first update the local AD database from the FAA's database and then
work all ADs out of the needs Analysis and needs compliance work states. By doing this you are
confident that no pending AD are unaddressed.

Enter New Inspection
To enter a new annual inspection select the following from the menu: Inspection->Enter New Aircraft
Annual Inspection. AMPro will begin the process of checking databases and generating forms for an
inspection. The N number of the aircraft previously selected in Equipment->Choose Existing Aircraft
and Mechanic will be the N number of the aircraft that the new inspection form will be generated for.
Follow the detailed instructions found in the Enter New Aircraft Annual Inspection section to fill out
the and save the inspection form. Once and inspection is entered, you may choose to save and view log
entries by selecting that button at the bottom of the form. This will generate and display a PDF form of
the annual or condition inspection for the airframe and all of its engines and for all ADs that have been
newly complied with. This PDF is saved in the AMPro_data_files/N_number directory. It can be
printed on label paper, signed and affixed to the logbook. The database holds a working copy for your
future reference.

Check For and Complete Scheduled Maintenance Items
As part of the maintenance process you can use the Maintenance->Scheduled Maintenance menu to
view and re-service any scheduled maintenance items. This provides both operator and the maintenance
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personnel a quick way to keep up on oil and air filter changes as previously mentioned. Refer to the
Scheduled Maintenance section above for details on how to use this feature.

Entry of Corrective Maintenance Items
If during the process of an inspection, or while performing scheduled maintenance, you find condition
issues that need to be resolved, and if those issues are not in the Scheduled Maintenance item list. You
can create and log entries for the corrective maintenance items. See the above Corrective Maintenance
section for details.

Create Work Reports
You may choose to create reports on the aircraft. This might be logically done after an inspection but
could be done at any time. See the section on reports above for details on the types and the process for
generating reports.
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Items That May Cause Confusion
Our observations of user attempts to use the AMPro program have shown us that the following topics
can cause confusion. We have included this section to help explain how to handle a few of the trickier
issues.

Computation of Component Total time on Airframe, Engine and Propeller
Remember that if the tachometer is older than the engine, prop or overhaul of the engine or prop, then
the hours on the that item (i.e.TTEng, TSMOH, TSTOH, TTProp) when the tachometer was last
changed will be negative.

Full AD Report Method of Compliance Explanation
In an attempt to limit the size of the full AD report and to improve its conciseness, the method of
compliance field in the Full_AD_report.pdf file will be limited to 2 lines or less. The data entered in the
ADs->Analyze ADs->Needs Compliance Entry field can be as long as you desire; but the text that gets
entered into the Full_AD_report.pdf file will be limited to two lines for the sake of conciseness. For
full details, the ADs->Analyze ADs->Compliance Completed Entry can be referenced.

Importing Databases
Importing databases in not supported on evaluation copies of the AMPro Program. If you are running
an evaluation copy of AMPro and you try to import a database, you will get a pop up dialog box
indicating that import is not supported.
To import a database in a non-evaluation (purchased) copy of AMPro, you must name the database
“aircraft.sql” and it must be placed in the c:\AMPro_aircraft_data directory. To import choose
File->Import entire database from .sql. The aircraft.sql file should have been previously created by
AMPro by the File->export entire database to .sql command.

Windows 8 administrator initial program crash
If you are running Windows 8 and you download and execute the setup as a non-administrator then the
program may crash. This may happen during the last step of the setup when you direct the setup to start
AMPro. This potential crash is because after AMPro is loaded you are trying to run it as a nonadministrator. The fix for this condition is to either run the program logged on as the administrator or
us Windows Explorer to go into the c:\Program Files (X86)\AMPro folder then right click on the
AMPro.exe application and select run as administrator. Windows 8 will remember that the program has
been run as an administrator and should not have further problems.

Reporting Bugs
If you think that you have found a bug in the program please report it and supply as much of the
following information as possible. The information will help us reproduce and identify the bug.
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Please provide:
1) A description of what you were trying to enter. This can often best be done by showing the
menus you were going through. For example if you found a bug while entering the total time on the
engine at last tach change you might explain that the tach was changed at 7000.0 hours and the engine
was top overhauled at 7300.0 hours and so you were attempting to set the TSMOH at -300 using the
the following menu sequence: Equipment->Edit Existing or Add New Aircraft or
Equipment->Nxxxy->Edit or Delete Nxxxy Right Engine->Enter hours on the following item when the
tachometer was last changed, TSMOH = -300
2) If the program crashed please include the AMPro_exe.log file. The location of this file and the
exact name will be displayed on the windows machine if the program crashes.
3) The version of the program you are running. This can be found in the main menu Help->Get
AMPro Revision
4) The database would be very helpful. This can be found at the same directory as the program
AMPro.exe. This is usually Program_files (x86)/AMPro. The database will be named
aircraft.db

Partial program Crashes
Occasionally, a user will report that they did something and that they think the program may have
crashed but they aren't sure what they did or if it really did in fact crash. This is typically reported by a
new user.
First, we intend to create software that is free of defect and if you can replicate the defect please
provide us with a bug report. However, in a complex world of differing versions of operating systems
and an infinitely varying set of computer configurations it is always possible to have bugs. The good
news is that as the program is used, the data entered is saved quite often. Thus a crash of accidental
power failure will not cause the loss of very much data. If you think that the program has crashed,
simply get out of the program by File->Exit or clicking the red x at the top corner and then restart the
program. You should be able to pick up right where you left off.

Features for future revisions
Importing a single aircraft into a multi aircraft database
Some users have asked for an import a single aircraft's database into a database holding multiple
aircraft. This is not currently supported. You may work around this by simply working with the single
aircraft's database as if it were a standalone entity. Importing and exporting it using the File->
Import/Export entire database.

IA pull down box for proof of AD compliance
When working through the ADs that have previously been complied with, the user is given the option
to enter information about the mechanic that signed the AD compliance when it was initially complied
with. Often many of the AD's will have been signed by the same mechanic. The current way that
AMPro works, the user will need to retype the name and or license number of the individual that signed
the compliance. Because so many AD are often signed by the same mechanic, retyping their name and
Number seems tedious. This tedium is most often seen in the following menus:
AD->analyze AD-> Needs Research → previously complied with.
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And
AD->analyze AD-> Compliance Completed
In a future revision we may choose to have a pull down box that allows the user to select one of the
previously used mechanics or to enter a new mechanic as the signer of an AD that has been previously
complied with.
If there are any questions or issues that have not been resolved with this user’s guide feel free to
contact Ron Simmons by telephone at (801) 298-7854 or by email at rsimmons@aircraft-inspectionsoftware.com
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